Symptom
When you attempt to send an email from the Print > Report or Automatic Report menus in QC-CALC, you may see the following messages if you are using Outlook:
or
An equivalent message may appear in Lotus Notes. Alternately, the automatic email appears in Lotus fully filled in, but doesn't automatically send itself until you click the Send button.
Cause
This is because QC-CALC previously used a technology called MAPI. This technology uses the local email client on the PC to send email. Due to the ever tightening of security for these applications, newer versions no longer allow outside applications to use them for the purpose of sending emails.
Resolution
We have resolved this issue as of QC-CALC 3.0.252. We now use SMTP to send mail through an authenticated server connection. This effectively avoids all use of the individual email client on the PC and eliminates security messages. In fact, it isn't even necessary to have an email client installed on the PC in order to use it.
VERY IMPORTANT: Unfortunately to accomodate a change to the QC-CALC installation, you must download the full version of QC-CALC 3.0.252 (or higher) and reinstall. Using the Help > Run Update menu command will not work in this case.
To do this, simply download a new evaluation from our website and install it right over your existing copy of QC-CALC 3.0 (Real-Time, SPC or Enterprise). All data, licensing and settings information will be preserved. It is just replacing the existing application. We apologize for this inconvenience, but it is unfortunately unavoidable.
To configure the general email settings in QC-CALC:
- Go to Tools > Options > Email.
- At the top, type your own name and email address as the sender. This information will be placed in the FROM section of the email. This way, if a recipient decides to reply to your email, it will come to you.
- If you have an Exchange or Notes server, you can uncheck the box that says Use Prolink's Default Server Setting and set your own SMTP server for use.
PLEASE NOTE: This is highly recommended to reduce traffic on Prolink's servers.
- Your IT department can help you with the SMTP server settings, but generally they follow the same standard as your email client uses. In Outlook, you can go to Tools > Email Accounts and view your email settings there. For these settings only the outbound setting are required.
More Information
For more information or if you have questions regarding this new functionality, please contact us at support@prolinksoftware.com.