CrypKey no longer works with NT Service Pack 6 (ver 2.2 - 2.4)
NT Service Pack 6 was installed the Crypkey license no Longer works
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written: 01/30/2006
last modified: 09/16/2024

SYMPTOM

You installed NT Service Pack 6 and the Crypkey license no Longer works but it was running before the service pack was installed


CAUSE

There is a known problem when NT Service Pack 6 is installed and QC-CALC's Crypkey license system is already running. The service pack removes the Crypkey services that is needed for our software.


RESOLUTION

This procedure removes and reinstalls the Crypkey service correctly:

  1. Log in as Administrator
  2. Run C:\WINNT\CKCONFIG.EXE and remove all directories from the list. Remove the directories by clicking the Remove button. Exit CKCONFIG by clicking the Close button.
  3. Open a DOS window (a Command prompt)
  4. Change directories to C:\PROLINK\QC-CALC\
  5. Make sure SETUPEX.EXE and CKS.EXE are present in that directory
  6. Type the following line and press Enter - SETUPEX /D
  7. Shut down the computer, turn off power for 10 seconds, and turn it back on
  8. Log on as Administrator again
  9. Open a DOS window (a Command prompt)
  10. Change directories C:\PROLINK\QC-CALC\
  11. Type the following line and press Enter - SETUPEX
  12. Check "Control panel" "Services" to make sure "CrypKey license" service is Automatic and Started, and check the license.

Applies To

QC-CALC Real-Time v.2.4
QC-CALC SPC 2.4
QC-CALC SPC Pro v.2.3
QC-CALC SPC Pro v.2.2