SYMPTOM
You installed NT Service Pack 6 and the Crypkey license no Longer works but it was running before the service pack was installed
CAUSE
There is a known problem when NT Service Pack 6 is installed and QC-CALC's Crypkey license system is already running. The service pack removes the Crypkey services that is needed for our software.
RESOLUTION
This procedure removes and reinstalls the Crypkey service correctly:
- Log in as Administrator
- Run C:\WINNT\CKCONFIG.EXE and remove all directories from the list. Remove the directories by clicking the Remove button. Exit CKCONFIG by clicking the Close button.
- Open a DOS window (a Command prompt)
- Change directories to C:\PROLINK\QC-CALC\
- Make sure SETUPEX.EXE and CKS.EXE are present in that directory
- Type the following line and press Enter - SETUPEX /D
- Shut down the computer, turn off power for 10 seconds, and turn it back on
- Log on as Administrator again
- Open a DOS window (a Command prompt)
- Change directories C:\PROLINK\QC-CALC\
- Type the following line and press Enter - SETUPEX
- Check "Control panel" "Services" to make sure "CrypKey license" service is Automatic and Started, and check the license.