SYMPTOM
Turning on or off a Record Filter takes a very long time.
CAUSE
There are several conditions that could cause a record filter to be slow to take effect. Having the QCC files on a network can cause problem depending on the network speed, but the most common reason is the number of records in the database. Because of that, if you limit the number of records to have QC-CALC look back on it can greatly improve the speed.
RESOLUTION
- Determine how far back is the max you will need to filter on (Last Week, Last Month, Last Year, etc.).
- Based on that, make an estimate of the max number of parts you may read in for that time period.
- Go to Tools - Options - Filters and look for the box called "Enable search limiting".
- Check the box on and for "Max records to search" enter in the amount you determined for step 2. We recommend entering in a slightly higher amount just for some saftely. So if the highest number you estimate is 500, enter in 1000. If it is 2000, enter in 2500 and so on.
- Click OK to save your changes.
- Turn on a Record Filter and see if you notice a speed improvement.